<!DOCTYPE html>
<html lang="en" xml:lang="en">
  <head>
    <meta name="viewport" content="width=device-width, initial-scale=1, maximum-scale=1, user-scalable=0"/>
    <meta name="robots" content="max-image-preview:large"/>
    <link rel="amphtml" href="https://www.lynnnews.co.uk/news/amp/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/"/>
    <meta property="article:author" content="https://www.facebook.com/lynnnews/"/>
    <meta property="article:published_time" content="2022-06-17Z04:20:00.0000000+01:00"/>
    <meta property="article:modified_time" content="2022-06-16Z11:24:05.0213050+01:00"/>
    <meta property="article:section" content="News"/>
    <meta property="article:tag" content="Arts and Showbiz"/>
    <meta property="article:tag" content="Kings Lynn"/>
    <link rel="canonical" href="https://www.lynnnews.co.uk/news/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/"/>
    <meta name="original-source" content="https://www.lynnnews.co.uk/news/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/"/>
    <meta property="og:url" content="https://www.lynnnews.co.uk/news/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/"/>
    <meta name="description" content="An unveiling of a colourful mammoth sculpture will be living in The Walks this summer as part of a GoGo Discover trail."/>
    <meta property="fb:app_id" content="361385861474524"/>
    <meta name="keywords" content="Arts and Showbiz, Kings Lynn"/>
    <meta property="og:locale" content="en_GB"/>
    <meta property="og:description" content="An unveiling of a colourful mammoth sculpture will be living in The Walks this summer as part of a GoGo Discover trail."/>
    <meta property="og:title" content="First glimpse of one of two prehistoric sculptures destined for this summer"/>
    <meta property="og:type" content="article"/>
    <meta property="og:site_name" content="Lynn News"/>
    <script type="application/ld+json">
      {
        "@context": "https://schema.org",
        "@type": "NewsArticle",
        "articleSection": "News",
        "headline": "First glimpse of one of two prehistoric sculptures destined for this summer",
        "keywords": [
          "Arts and Showbiz",
          "Kings Lynn"
        ],
        "thumbnailUrl": "https://www.lynnnews.co.uk/_media/img/YDP6F3WIASTO4LKCL4N7.jpg",
        "author": {
          "@type": "Person",
          "name": "Jenny Beake",
          "url": "https://www.lynnnews.co.uk/authors/jenny-beake"
        },
        "creator": {
          "@type": "Person",
          "name": "Jenny Beake",
          "url": "https://www.lynnnews.co.uk/authors/jenny-beake"
        },
        "publisher": {
          "@type": "NewsMediaOrganization",
          "logo": {
            "@type": "ImageObject",
            "url": "https://www.lynnnews.co.uk/site-logo.png"
          },
          "name": "Lynn News"
        },
        "dateCreated": "2022-06-16T11:24:05Z",
        "dateModified": "2022-06-16T11:24:05Z",
        "datePublished": "2022-06-17T04:20:00Z",
        "image": [
          "https://www.lynnnews.co.uk/_media/img/YDP6F3WIASTO4LKCL4N7.jpg",
          "https://www.lynnnews.co.uk/_media/img/GMQ1FJOK4BJDQX2TTY90.jpg",
          "https://www.lynnnews.co.uk/_media/img/7RK6H5HNQ67IV32VFVW9.jpg",
          "https://www.lynnnews.co.uk/_media/img/XHDE45XNUXFUICNYCH6M.jpg"
        ],
        "mainEntityOfPage": {
          "@type": "WebPage",
          "@id": "https://www.lynnnews.co.uk/news/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/"
        },
        "url": "https://www.lynnnews.co.uk/news/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/",
        "speakable": {
          "@type": "SpeakableSpecification",
          "cssSelector": [
            ".HeadingFont"
          ]
        }
      }
    </script>
    <meta property="og:image" content="https://www.lynnnews.co.uk/_media/img/YDP6F3WIASTO4LKCL4N7.jpg"/>
    <meta property="og:image:width" content="557"/>
    <meta property="og:image:height" content="384"/>
    <title>First glimpse of one of two prehistoric sculptures destined for King’s Lynn this summer</title>
    <meta name="twitter:card" content="summary_large_image"/>
    <meta name="twitter:site" content="@TheLynnNews"/>
    <meta name="twitter:creator" content="@TheLynnNews"/>
    <meta name="gal_ab" content="true"/>
    <link type="text/css" rel="stylesheet" href="/_site/bundle-v6490876.css"/>
    <script type="text/javascript" src="/_site/bundle-v6437440.js"></script>
    <link type="text/css" rel="stylesheet" href="/_resources/font-awesome-svg-5.10.2-v5099857.css"/>
    <link type="text/css" rel="stylesheet" href="https://use.fontawesome.com/releases/v5.6.1/css/all.css"/>
    <script type="text/javascript" src="//js-sec.indexww.com/ht/p/185246-98331710595893.js" async></script>
    <script type="text/javascript" src="https://geo.dailymotion.com/libs/player/x88q7.js"></script>
    <script type="text/javascript" src="/_resources/bcovery-v5742287.js"></script>
    <script type="text/javascript" src="/_resources/jquery.nicescroll-v2082836.js" async></script>
    <script type="text/javascript" src="https://platform.twitter.com/widgets.js" async></script>
    <link rel="shortcut icon" type="image/x-icon" href="/favicon.ico" />
    <link rel="apple-touch-icon" href="/apple-touch-icon.png">
    <link rel="manifest" href="/manifest.json">
    <script type="text/javascript">
      var _pluginConfig = {
        "Cmp" : true,
        "Gpt" : true,
        "Carbon" : { "Code" : "be3562f65f" },
        "ChartBeat" : { "Code" : "66467", "Domain" : "lynnnews.co.uk", "Cookies" : true, "User" : "None", "Section" : "Arts and Showbiz,Kings Lynn", "Authors" : "Jenny Beake" },
        "Comscore" : { "C1" : "2", "C2" : "6035892" },
        "Lotame" : { "Code" : "12965" },
        "MoneyPenny" : { "Code" : "87b53a89-42f1-4781-818b-cd368c7d770e" },
        "OutBrain" : { "Url" : "https://widgets.outbrain.com/outbrain.js", "Code" : "ILIFF102MO2CO2FD6B9C2QP2D" }
      };
      var _pluginManager = _pluginManager || new Common.PluginManager();
    </script>
    <script async src="https://www.googletagmanager.com/gtag/js?id=UA-117709099-1"></script>
    <script>
      window.dataLayer = window.dataLayer || [];
      function gtag(){dataLayer.push(arguments);}
      gtag('js', new Date());
      gtag('config', 'UA-117709099-1', { 'anonymize_ip': true });
      gtag('config', 'G-0T0BJZG9VS', { 'anonymize_ip': true });
    </script>
    <script type="text/javascript" async="async" src="https://www.googletagservices.com/tag/js/gpt.js"></script>
    <script type="text/javascript">
      var dfpConfig = { DesktopUnit: "~154725070,22695181782~lynnnews_desktop~news", MobileUnit: "~154725070,22695181782~lynnnews_mobile~news", Section: "news" };
    </script>
  </head>
  <body class="responsive">
    <script type="text/javascript" src="/wp-banners.js"></script>
<header id="header"><style>.SubscribeMobile{display:none!important}#headerSpacer{height:194px!important}.MobileBanner{top:38px!important}@media screen and (max-width:650px){#headerSpacer{height:100px!important}.leaderboard{padding:30px 0 0 0!important}}</style> <div class="SubsHeader"> <div class="row"> <div class="col-12 col-lg-12"> <p style="margin-top:-2px;"><b>More news, no ads <i class="fas fa-long-arrow-alt-right"></i></b></p> <a href="/subscribe/" class="SubsButton"><b>LEARN MORE</b></a> </div> </div> </div><div id="headerSearch"> <form class="search s top" method="get" action="/search/"> <div class="row"> <div class="offset-lg-3 col-lg-6"> <input class="typesearch sb" type="text" name="q" placeholder="What would you like to find?"/> <button type="submit" class="sbtn"><i class="fas fa-search fa-2x"></i></button> </div> </div> </form> </div><div class="mobilemenu d-lg-none"> <div class="row no-gutters mobilemenu navbar"> <div class="col-2 account"><div> <a href="/_api/transfer/transfer/login" rel="nofollow"> <span class="LoginFirst">Sign in&nbsp;&nbsp;</span><span class="usericon"><i class="fas fa-user-circle"></i></span> </a> </div></div> <div class="col-6 col-sm-3"> <a class="navbar-brand m-0 p-0" href="/"><p class="ml-2 mb-0">SINCE 1841</p><img src="/_assets/lynnnews.svg" class="img-fluid mx-auto" alt="Lynn News"/></a> </div> <div class="col-1 searchmob"> <div id="dropmobile"><a class="btn-search droptoggle" data-toggle="collapse"><i class="fas fa-search"></i></a> </div> </div> <div class="col-2 white text-center"> <button type="button" class="navbar-toggler w-100" data-toggle="collapse" data-target=".navbar-collapseMobile">&#x2630;</button> </div> </div> <div class="collapse navbar-collapseMobile" id="navbarSupportedContentMobile"> <div><a class="change-consent" onclick="window.__tcfapi('displayConsentUi', 2, function() {} );"><i class="fas fa-cog"></i> Change consent</a><div class="topmenu"> <div class="PremMob w-100"> <a href="https://premium.lynnnews.co.uk/" target="_blank" rel="noopener"> <i class="fas fa-user-circle" aria-hidden="true"></i> <span class="Txt">Premium login</span> </a> </div> <ul class="nav navbar-nav"> <li><a href="http://www.photos.iliffemedia.co.uk" target="_blank">Photo sales</a></li> <li>|</li> <li><a href="http://iliffemedia.co.uk" target="_blank">Iliffe Media</a></li> <li>|</li> <li><a href="/announcements/">Announcements</a></li> <li>|</li> <li><a href="/advertise-with-us/">Advertise</a></li> <li>|</li> <li><a href="https://www.visiteastangliaguide.co.uk" target="_blank">Visit East Anglia</a></li> <li>|</li> <li><a href="http://lynn.yourlocalnotices.com/" target="_blank">Public Notices</a></li> <li>|</li> <li><a href="https://property.lynnnews.co.uk/" target="_blank">Homes</a></li> <li>|</li> <li><a href="/newsletter/">Newsletter</a></li> <li>|</li> <li><a href="https://www.imads.co.uk/" target="_blank">Place an ad</a></li> <li>|</li> <li><a href="https://twitter.com/thelynnnews?lang=en" target="_blank"><i class="fab fa-twitter"></i></a></li> <li>|</li> <li><a href="https://www.facebook.com/lynnnews" target="_blank"><i class="fab fa-facebook-f"></i></a></li> </ul> </div> <div class="clearfix"></div> <div class="container"> <div class="row mobweather pb-2"> <div class="col-12 text-center"><div class="WeatherHomeInfo mt-2"> <a href="/weather/"> <i class="wi wi-day-sunny" alt="Mainly Fair "></i> <span class="Temp">31&deg;</span><span class="TempLater"> | 14&deg;</span> </a> </div></div> </div> <ul class="p-2 dropnav"><li><span><a href="/">Home</a></span></li> <li class="menuParent"> <span>News <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/news/">News</a></li> <li><a href="/news/coronavirus/">Coronavirus</a></li> <li><a href="/news/crime/">Crime</a></li> <li><a href="https://digital.imnews.app/" target="_blank">E-edition</a></li> <li><a href="/news/education/">Education</a></li> <li><a href="/news/environment/">Environment</a></li> <li><a href="/news/health/">Health</a></li> <li><a href="/news/in-depth/">In Depth</a></li> <li><a href="/news/in-full/">In Full</a></li> <li><a href="/news/offbeat/">Offbeat</a></li> <li><a href="/news/opinion/">Opinion</a></li> <li><a href="/news/politics/">Politics</a></li> <li><a href="/news/transport/">Transport</a></li> <li><a href="/news/womens-voices/">Women's Voices</a></li> <li><a href="/news/your-say/">Your Say</a></li> </ul> </div> </li> <li class="menuParent"> <span>Education <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/education/">Education</a></li> </ul> </div> </li> <li class="menuParent"> <span>Sport <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/sport/">Sport</a></li> <li><a href="/sport/football/">Football</a></li> <li><a href="/sport/more-sport/">More Sport</a></li> <li><a href="/sport/speedway/">Speedway</a></li> <li><a href="/sport/in-full/">In Full</a></li> </ul> </div> </li> <li class="menuParent"> <span>What's On <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/whats-on/">What's On</a></li> <li><a href="/whats-on/arts/">Arts and Screen</a></li> <li><a href="/whats-on/music/">Music</a></li> <li><a href="/whats-on/theatre-and-comedy/">Theatre and Comedy</a></li> <li><a href="/whats-on/in-full/">In Full</a></li> </ul> </div> </li> <li class="menuParent"> <span>Lifestyle <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/lifestyle/">Lifestyle</a></li> </ul> </div> </li> <li class="menuParent"> <span>Business <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/news/business/">Business</a></li> </ul> </div> </li> <li class="menuParent"> <span>Directory <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li></li> </ul> </div> </li> <li class="menuParent"> <span>Contact <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/contact-us/">Contact</a></li> </ul> </div> </li> <li class="menuParent"> <span>Subscribe <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/subscribe/">Subscribe</a></li> </ul> </div> </li> <li class="menuParent"> <span>Advertise <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/advertise-with-us/">Advertise</a></li> </ul> </div> </li> <li class="menuParent"> <span>Jobs <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="https://www.imjobs.co.uk/" target="_blank">Jobs</a></li> </ul> </div> </li> <li class="menuParent"> <span>Women's Voices <i class="fas fa-chevron-down"></i> </span> <div class="menuChildren"> <ul> <li><a href="/news/womens-voices/">Women's Voices</a></li> </ul> </div> </li></ul> </div> </div> </div></div><div class="desktopmenu d-none d-lg-block"> <nav class="navbar navbar-expand-lg navbar-light top" id="menu"> <div class="container"> <div class="row no-gutters w-100"> <div class="col-lg-11"> <div class="FirstMenu"> <div class="PremDesk"> <a href="http://premium.lynnnews.co.uk/" target="_blank" rel="noopener"> <i class="fas fa-user-circle" aria-hidden="true"></i> <span class="Txt">Premium login</span> </a> </div> <ul class="nav navbar-nav"> <li><a href="http://www.photos.iliffemedia.co.uk" target="_blank">Photo sales</a></li> <li>|</li> <li><a href="http://iliffemedia.co.uk" target="_blank">Iliffe Media</a></li> <li>|</li> <li><a href="/announcements/" target="_blank">Announcements</a></li> <li>|</li> <li><a href="https://www.visiteastangliaguide.co.uk" target="_blank">Visit East Anglia</a></li> <li>|</li> <li><a href="http://lynn.yourlocalnotices.com/" target="_blank">Public Notices</a></li> <li>|</li> <li><a href="https://property.lynnnews.co.uk/" target="_blank">Homes</a></li> <li>|</li> <li><a href="https://digital.imnews.app/" target="_blank">E-edition</a></li> <li>|</li> <li><a href="https://www.imads.co.uk/" target="_blank">Place an ad</a></li> <li>|</li> <li><a href="/newsletter/">Newsletter</a></li> </ul> </div> </div> <div class="col-lg-1 text-right socialsearch"> <ul> <li><a href="https://twitter.com/thelynnnews?lang=en" target="_blank"><i class="fab fa-twitter"></i></a></li> <li><a href="https://www.facebook.com/lynnnews/" target="_blank"><i class="fab fa-facebook-f"></i></a></li> <li class="d-none d-sm-block"> <div id="drop"><a class="btn-search droptoggle"><i class="fas fa-search"></i></a></div> </li> </ul> </div> </div> </div> </nav> <div class="LogoSection"> <div class="container"> <a href="/"><img src="/_assets/lynnnews.svg" alt="Lynn News" class="main-logo"/></a> <p class="ml-2 mb-0">SINCE 1841</p> <div class="WeatherHome float-right d-none d-sm-none d-lg-block"><a href="/weather/"> <i class="wi wi-day-sunny float-left" alt="Mainly Fair "></i> <div class="WeatherHomeInfo"> <span class="Temp">31&deg;</span><span class="TempLater">| 14&deg;</span> <div class="clearfix" style="height: 1px;"></div> <span class="FiveDays" style="">5 days <i class="fa fa-angle-right" aria-hidden="true"></i></span> </div> </a></div> </div> </div> <div class="DesktopMenuBar"> <div class="container"> <div class="row no-gutters"> <div class="col-auto mr-auto"> <div class="LeftMenu"> <div class="nav navbar-nav dropdown mmenu"> <ul><li><span><a href="/">Home</a></span></li> <li class="Parent nav-item dropdown"> <span><a href="/news/" class="selected">News</a></span> <div class="menuChildren dropdown-menu-d"><ul><li><a href="/news/coronavirus/">Coronavirus</a></li> <li><a href="/news/crime/">Crime</a></li> <li><a href="https://digital.imnews.app/" target="_blank">E-edition</a></li> <li><a href="/news/education/">Education</a></li> <li><a href="/news/environment/">Environment</a></li> <li><a href="/news/health/">Health</a></li> <li><a href="/news/in-depth/">In Depth</a></li> <li><a href="/news/in-full/">In Full</a></li> <li><a href="/news/offbeat/">Offbeat</a></li> <li><a href="/news/opinion/">Opinion</a></li> <li><a href="/news/politics/">Politics</a></li> <li><a href="/news/transport/">Transport</a></li> <li><a href="/news/womens-voices/">Women's Voices</a></li> <li><a href="/news/your-say/">Your Say</a></li> </ul></div></li> <li class="Parent nav-item dropdown"> <span><a href="/education/">Education</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/sport/">Sport</a></span> <div class="menuChildren dropdown-menu-d"><ul><li><a href="/sport/football/">Football</a></li> <li><a href="/sport/more-sport/">More Sport</a></li> <li><a href="/sport/speedway/">Speedway</a></li> <li><a href="/sport/in-full/">In Full</a></li> </ul></div></li> <li class="Parent nav-item dropdown"> <span><a href="/whats-on/">What's On</a></span> <div class="menuChildren dropdown-menu-d"><ul><li><a href="/whats-on/arts/">Arts and Screen</a></li> <li><a href="/whats-on/music/">Music</a></li> <li><a href="/whats-on/theatre-and-comedy/">Theatre and Comedy</a></li> <li><a href="/whats-on/in-full/">In Full</a></li> </ul></div></li> <li class="Parent nav-item dropdown"> <span><a href="/lifestyle/">Lifestyle</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/news/business/">Business</a></span> </li> <li class="Parent nav-item dropdown"> <span></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/contact-us/">Contact</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/subscribe/">Subscribe</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/advertise-with-us/">Advertise</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="https://www.imjobs.co.uk/" target="_blank">Jobs</a></span> </li> <li class="Parent nav-item dropdown"> <span><a href="/news/womens-voices/">Women's Voices</a></span> </li></ul> </div> </div> </div> <div class="col-auto float-right text-right p-2 text-center LoginBtn account"><div> <a href="/_api/transfer/transfer/login" rel="nofollow"> <span class="LoginFirst">Sign in&nbsp;&nbsp;</span><span class="usericon"><i class="fas fa-user-circle"></i></span> </a> </div></div> </div> </div> </div> </div> </header><div id="headerSpacer"></div> <div id="EwrapHead"></div> <div id="EWrap"> <div class="MainSite"> <div class="container white"> <div class="leaderboard text-center"> <div class="leader"><span id="ad_Head-Leader" class="advert" data-provider="3" data-devices="d" data-format="['billboard',970,1], ['lb1',728,90]"></span></div> <div class="banner"><span id="ad_Head-Banner" class="advert" style="width: 468px; height: 60px;" data-provider="3" data-devices="t" data-format="['bannertablet',468,60]"></span></div> <div class="mobile"><span id="ad_Head-Mobile" class="advert" style="width: 320px; height: 50px;" data-provider="3" data-devices="m" data-format="['bannermobile',320,50]"></span></div> <div class="Bread text-center pt-4 pb-3"><p> <a href="/" class="first"><i class="fa fa-home icon-2x"></i> Home</a> <i class="fa fa-angle-right"></i>&nbsp; <a href="/news/">News</a> <i class="fa fa-angle-right"></i>&nbsp; Article</p></div> </div> </div> <div class="SubscribeTab d-none d-lg-block"> <a href="/subscribe/"><b>Subscribe Now</b></a> </div><script type="text/javascript">$(document).ready(function(){$(".external").each(function(){var a=$(this);var c=a.find("iframe");if(c.length>0){var b=parseInt(c.attr("height"),10);if(!isNaN(b)){a.css({paddingBottom:"auto",height:b+"px"})}}})});</script> <div class="container white"> <div class="row"> <div class="col-lg-8 ArticleInner"> <article><script type="text/javascript"> function loadGrids() { siteResponsive.loadArticlePanels(); } function loadFlourish(){ var flourish = $(".flourish"); if(flourish.length){ console.log("load flourish embed"); $.getScript("https://public.flourish.studio/resources/embed.js", function(){ }); } } function agatePremiumContentRendered() { siteResponsive.refreshFeatures(); $(".freePreviewFade").detach(); twttr.widgets.load(); loadGrids(); loadFlourish(); } $(document).ready(function() { loadGrids(); }); </script> <h1 class="HeadingFont">First glimpse of one of two prehistoric sculptures destined for King’s Lynn this summer</h1> <hr /> <div class="row"> <div class="col-12 col-md-10 col-lg-10"> <div class="authorName"><i class="fas fa-user-circle"></i> <span>By </span> <a href="/authors/jenny-beake" > Jenny Beake</a> </div> <div class="clearfixNone"></div> <div class="ArticleDate"><strong><i class="far fa-clock"></i> Published:</strong> 05:20, 17 June 2022 </div> </div> <div class="col-12 col-md-2 col-lg-2"> <div id="commentsCountTop" class="comments-count"><a href="#comment-box" ><span></span></a></div> </div> </div> <hr /> <div class="SubsArticleStrap"> <div class="row"> <div class="col-12 col-lg-12"> <div class="row"> <div class="col-lg-12"> <p><b> More news, no ads <i class="fas fa-long-arrow-alt-right"></i></b></p> <a href="/subscribe/" class="SubsButton"><b>LEARN MORE</b></a> </div> </div> </div> </div> </div> <hr /> <div class="row no-gutters SocialArticleIcons"> <div class="col twitter"><a href="javascript:void(0);" class="share twitter"><i class="fab fa-twitter-square"></i></a></div> <div class="col facebook"><a href="javascript:void(0);" class="share facebook"><i class="fab fa-facebook-square"></i></a></div> <div class="col google-plus"><a href="javascript:void(0);" class="share googleplus"><i class="fab fa-google-plus-square"></i></a></div> <div class="col pinterest"><a href="javascript:void(0);" class="share pinterest"><i class="fab fa-pinterest-square"></i></a></div> <div class="col linkedin"><a href="javascript:void(0);" class="share linkedin"><i class="fab fa-linkedin"></i></a></div> <div class="col reddit"><a href="javascript:void(0);" class="share reddit"><i class="fab fa-reddit-square"></i></a></div> <div class="col emails"><a href="javascript:void(0);" class="share email"><i class="fas fa-envelope"></i></a></div> </div> <hr /> <div class="pagestory"> <!-- Article Start --><p>After months of anticipation, hundreds of people were treated to a preview of some of the T.rex and Steppe Mammoth sculptures set to stomp across the county for the GoGoDiscover trail and two of those will be coming to Lynn.</p><p>The sculptures were unveiled at the GoGoDiscover launch event in Norwich on Thursday, June 16, which brought together artists, sponsors and logistical partners who are involved in the project.</p><p>One of the nine sculptures unveiled on the night was Big Top, a vibrant and colourful circus themed mammoth, which is due to take residence in The Walks when the GoGoDiscover trail goes live on Monday, June 27.</p><figure><img class="rthmb" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 558 744'%3E%3C/svg%3E" alt="Big Top. Photo credit: RMG Photography (57357134)" data-root="/_media/img/" data-path="GMQ1FJOK4BJDQX2TTY90.jpg" data-ar="0.75"/><noscript><img src="/_media/img/GMQ1FJOK4BJDQX2TTY90.jpg" alt="Big Top. Photo credit: RMG Photography (57357134)"/></noscript><figcaption>Big Top. Photo credit: RMG Photography (57357134)</figcaption></figure><p>Sponsored by West Norfolk Council, Big Top has been decorated by art teacher, set designer and theatrical scenic painter, Sophie Li-Rocchi.</p><p>Sophie has created more than 30 large scale dramatic sets for plays at Gresham’s Prep School, where she is head of art.</p><span id="ad_907697797" class="advert" style="width: 300px; height: 250px;" data-provider="3" data-devices="d" data-format="['mpu2',300,250]"></span> <span id="ad_488634329" class="advert" style="width: 300px; height: 250px;" data-provider="3" data-devices="t" data-format="['mpu1',300,250]"></span> <span id="ad_998789494" class="advert" style="width: 300px; height: 250px;" data-provider="3" data-devices="m" data-format="['mpu1',300,250]"></span> <p>Sophie Li-Rocchi, who decorated Big Top said: "It was so much fun creating the design for Big Top. The mammoth’s body shape, with its huge blank sides and domed back, lent itself perfectly to being transformed into a circus tent.</p><figure><img class="rthmb" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 360 780'%3E%3C/svg%3E" alt="Sophie Li-Rocchi painting Big Top, the mammoth. (57357131)" data-root="/_media/img/" data-path="7RK6H5HNQ67IV32VFVW9.jpg" data-ar="0.46"/><noscript><img src="/_media/img/7RK6H5HNQ67IV32VFVW9.jpg" alt="Sophie Li-Rocchi painting Big Top, the mammoth. (57357131)"/></noscript><figcaption>Sophie Li-Rocchi painting Big Top, the mammoth. (57357131)</figcaption></figure><p>"I love to paint on a large scale and in bright colours with bold black outlines, details and highlights, which was ideal for creating the drama and magic needed for a circus mammoth.</p><p>"It’s always good to see other people’s reactions to your work, which is one of the amazing parts of being involved as an artist on the GoGoDiscover trails."</p><span id="teads" class="teads-advert advert" data-provider="3" data-devices="dtm" data-format="['teads',2,1]"></span> <p>Big Top is one of two GoGoDiscover trail sculptures destined for Lynn this summer.</p><figure><img class="rthmb" src="data:image/svg+xml,%3Csvg xmlns='http://www.w3.org/2000/svg' viewBox='0 0 4000 4000'%3E%3C/svg%3E" alt="Big Top. Photo credit: RMG Photography (57357137)" data-root="/_media/img/" data-path="XHDE45XNUXFUICNYCH6M.jpg" data-ar="1.00"/><noscript><img src="/_media/img/XHDE45XNUXFUICNYCH6M.jpg" alt="Big Top. Photo credit: RMG Photography (57357137)"/></noscript><figcaption>Big Top. Photo credit: RMG Photography (57357137)</figcaption></figure><p>The second sculpture is set to be stationed at King’s Staithe Square, but its name and design will remain a secret until the trail launches to the public.</p><p>Pete Marron, GoGoDiscover project manager, said: "It’s been a joy to finally share sculptures such as Big Top with the local community.</p><div class="OUTBRAIN" data-ob-contentUrl="https://www.lynnnews.co.uk/news/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/" data-widget-id="AR_2" data-ob-installation-key="ILIFF102MO2CO2FD6B9C2QP2D"></div><p>"Big Top is exciting, vivid and bright, and will sit beautifully at The Walks to be enjoyed by residents and visitors alike.</p><p>"We’ve seen the hard work and commitment of so many inspiring artists and invaluable sponsors, that to be able to showcase some of the show-stopping designs has further driven excitement and anticipation ahead of the trail starting on Monday, June 27."</p><div id="article_panel_LatestNews" class="articlePanel" data-type="LatestNews" data-path="" data-devices="dtm"></div> <p>This year’s GoGoDiscover trail runs from Monday, June 27, to Saturday, September 10, and sees a prehistoric posse of 79 T.rex and Steppe Mammoth sculptures stomp across the streets of Norwich and Norfolk.</p><p>GoGoDiscover is delivered by East Anglian charity, Break, in partnership with Wild in Art.</p><p>Through donations, app downloads, events, merchandise sales and an auction of sculptures in September, the trail is hoping to raise valuable funds to make life better for children and young people on the edge of care, in care and leaving the care system.</p><p>Rachel Cowdry, chief executive officer at Break, said: "Thanks to all the people involved in the trail we are able to continue to offer our support and guidance to the young people and adults we work with who face mammoth expectations when they leave care.</p><p>"Our aim is to make that transition a little smoother by presenting a lifelong offer of support and standing by their side in whatever challenges they face."</p><p>Trailgoers will be able to locate and identify all 79 of the prehistoric visitors using the new GoGoDiscover app (£1.79), available from the Apple appstore or Google playstore, or by picking up a GoGoDiscover trail map (suggested donation £1) from a variety of trail map hubs including the Duke’s Head Hotel in Lynn, the Pensthorpe gift shop, Holkham, and Break retail shops across the county.</p><p>For more information visit <a href="http://break-charity.org/gogodiscover">here<p></a></p><!-- Article End --> <div class="clearfixNone"></div> <hr /> <div class="CatKey"> <a href="/categories/arts-and-showbiz" class="article-category-link">Arts and Showbiz</a> <a href="/categories/kings-lynn" class="article-category-link">Kings Lynn</a> <a href="/authors/jenny-beake" class="article-category-link"> Jenny Beake</a> </div> <hr /> </div> <script type="text/javascript"> _pluginManager.setTargetValue("articleID", "9259449"); </script> <div id="comment-box"></div> <script type="text/javascript" language="javascript"> var comments = new Comments.CommentBox({ siteName: "Iliffe Media", groupName: "Iliffe Media", pageId: 671281, pageSize: 20, pagePath: "/news/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/", collapsible: true, showHeaderCount: true, showToggleCount: false, links: { rules: "https://www.iliffemedia.co.uk/house-rules/" } }); </script> <div class="clearfix"></div> <div class="clearfix"></div><div class="OUTBRAIN" data-ob-contentUrl="https://www.lynnnews.co.uk/news/first-glimpse-of-one-of-two-prehistoric-sculptures-destined-9259449/" data-widget-id="AR_1" data-ob-installation-key="ILIFF102MO2CO2FD6B9C2QP2D"></div></article> </div> <div class="col-12 col-md-12 col-lg-4 sidebar"> <aside><style>@media screen and (max-width:769px){.ArticleSidebar{display:none!important}}</style> <div class="ArticleSidebar d-none d-sm-none d-md-block d-lg-block"> <div class="MPU mb-3 text-center"><span id="ad_MPU1" class="advert" style="width: 300px; height: 250px;" data-provider="3" data-devices="d" data-format="['mpu1',300,250]"></span></div><div class="lynneduplug featuredblock h-100 text-center"> <a href="https://www.iliffemediapromotions.co.uk/lynn-education-awards/" target="_blank"> <div class="row"> <div class="col"> <h3>EDUCATION AWARDS 2022</h3> </div> </div> <p>Nominate now!</p> </a> </div> <div class="clearfix"></div><div class="titleline_color mb-3"> <h3 class="title_color">MOST READ</h3> </div> <div class="clearfix"></div> <div class="fetchPanel" data-url="/Panels/Most-Read/"></div><div class="MPU mb-3"><span id="ad_MPU4" class="advert" style="width: 300px; height: 250px;" data-provider="3" data-devices="d" data-format="['mpu4',300,250]"></span></div> <div class="d-none d-sm-block d-md-block d-lg-block"><script src="//get.s-onetag.com/4357d25f-0b90-40b5-b8ec-b61b66b8ab43/tag.min.js" async="" defer=""></script></div></div></aside> </div> <div class="clearfix"></div> <div class="row"> <div class="col-12 col-sm-12 col-md-12 col-lg-12"></div> </div> </div> </div></div><footer> <div class="container"> <div class="row"> <div class="col-12 col-sm-6 col-lg-3"> <a href="http://iliffemedia.co.uk" target="_blank"> <img src="/_assets/iliffe_media_logo.png" class="img-fluid" alt="Iliffe Media Logo"/> </a> </div> <div class="col-12 col-sm-6 col-lg-9"> <div class="mt-3"> <a href="/rss-feeds/"><i class="fas fa-rss-square fa-2x" title="RSS"></i></a> <a href="https://www.facebook.com/lynnnews/" target="_blank"><i class="fab fa-facebook fa-2x" title="Facebook"></i></a> <a href="https://twitter.com/thelynnnews?lang=en" target="_blank"><i class="fab fa-twitter-square fa-2x" title="Twitter"></i></a> </div> </div> </div> <div class="clearfix"></div> <hr class="custom"/> <div class="clearfix"></div> <div class="row"> <div class="col-12 col-sm-3 col-lg-3"> <ul class="pl-0"> <li><a href="/about-us/">About us</a> </li> <li><a href="/news/">News</a> </li> <li><a href="/whats-on/">What's On</a></li> </ul> </div> <div class="col-12 col-sm-3 col-lg-3"> <ul class="pl-0"> <li><a href="/contact-us/">Contact</a></li> <li><a href="/newsletter/">Newsletter</a></li> <li><a href="https://www.imjobs.co.uk/jobs/king-s-lynn/" target="_blank">Find Jobs in King's Lynn</a></li> </ul> </div> <div class="col-12 col-sm-3 col-lg-3"> <ul class="pl-0"> <li><a href="/advertise-with-us/">Advertise</a></li> <li><a href="/sport/">Sport</a></li> <li><a href="/lifestyle/">Lifestyle</a></li> </ul> </div> <div class="col-12 col-sm-3 col-lg-3"> <a href="https://www.ipso.co.uk/" target="_blank"><img src="/_assets/ipso_regulated.jpg" class="img-fluid IPSOLogo" alt="IPSO Regulated Logo"/></a> </div> </div> <div class="clearfix"></div> <hr class="custom"/> <div class="clearfix"></div> <div class="row small"> <div class="col-md-6 col-lg-6 text-center text-lg-left">&#xA9;&nbsp;2022&nbsp;- Iliffe Media Publishing Ltd. All rights reserved.</div> <div class="col-md-6 col-lg-6 terms text-center text-lg-right"> <a href="http://iliffemedia.co.uk/terms-and-conditions/" target="_blank">Terms</a> - <a href="http://iliffemedia.co.uk/privacy-policy/" target="_blank">Privacy Policy</a> - <a href="/sitemap/">Sitemap</a> - <a href="/contact-us/">Contact</a> </div> </div> </div> </footer><div id="clickSink"></div> <div id="cookiePopup"> <div class="container-fluid"> <div class="row"> <div class="col-9 col-md-10 col-lg-10"> <span class="cookietext"> This site uses cookies. By continuing to browse the site you are agreeing to our use of cookies - <a class="learnmore" href="http://iliffemedia.co.uk/cookies-policy/" target="_blank">Learn More</a></span></div> <div class="col-3 col-md-2 col-lg-2 mt-2 mt-lg-0"> <a id="cookieClose" class="btn btn-secondary submit"> <i class="fas fa-check pr-1 pl-1"></i> AGREE</a> </div> </div> </div> </div><span id="ad_DHTML1" class="advert" data-provider="3" data-devices="dt" data-format="['dhtml1',1,1]"></span><span id="ad_DHTMLM1" class="advert" data-provider="3" data-devices="m" data-format="['dhtmlm1',1,1]"></span></div><script type="text/javascript">var elginConfig={map:{swLat:52.68608008502249,swLng:0.2909092982449693,neLat:52.80828087420656,neLng:0.4927830775418443}};</script><script type="text/javascript" async="async" src="https://widgets.outbrain.com/outbrain.js"></script>  </body>
</html>
